Results 1 to 1 of 1

Thread: Temperature sensors on '92 LB4

  1. #1

    Temperature sensors on '92 LB4

    I've been trying to chase down the cause of rough idle & misfiring on my 1992 S-10 4.3L v6 TBI (LB4) and for a while I was getting a code 15, engine too cold. I replaced the coolant temp sensor, despite the fact that the engine temp gauge was displaying the same as always. The trouble code went away but had zero influence on engine performance. While getting advice from a professional mechanic, he said I should replace the air intake temperature sensor.

    I can NOT find any other temperature sensors around the intake manifold on this engine. BUT on the GM parts-online site and on several car parts sites when I search for temperature sensors I get a coolant temperature sensor AND ALSO an "air charge" or "air intake" temperature sensor that looks a bit similar to the coolant sensor but definitely different. All these web sites indicate that this air intake temp sensor fits my specific car. The mechanic also insists that I must have an air intake temp sensor for the TBI injection but my Haynes manual doesn't mention anything like that name (only the coolant temp sensor).

    Does anyone have a clue whether my '92 TBI LB4 is supposed to have an air intake temperature sensor and where it would be located?

  2. # ADS
    Circuit advertisement
    Join Date
    Always
    Posts
    Many

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •