Results 1 to 5 of 5

Thread: 1999 3.8 hard to start and rough idle

  1. #1
    Newbie dom_'s Avatar
    Join Date
    Apr 2018
    Location
    Storm lake, IA
    Posts
    5

    1999 3.8 hard to start and rough idle

    I'd like to start out by apologizing in advance if there's already a thread on an issue similar to mine. I did some searching but didn't find anything helpful.
    I've owned my 1999 Camaro for 4 years now, and it ran fine for the first year and a half or so. Then, one day in the middle of summer, it started to have trouble starting. It never failed to start, but would take six or seven seconds of cranking and sputtering to start, and would struggle to get up to 1000 RPM. If I let it run for ten seconds, shut it off, turned it back on for ten seconds, then started it, it would usually start just fine but would still run slightly rough. For some reason, this was never a problem if the car had been sitting for a whole day between starts. For the next two years, it would do that during the warm months, but wouldn't be an issue during the winter. Now it's doing it in the cold weather too.
    I've changed the spark plugs, put MSD wires in, cleaned the throttle body (which was full of oily residue), replaced the PCV valve (which fixed that issue), cleaned the MAF, and made no difference. I gave up and took it into the shop. They tested the fuel pressure, and reported that the pressure was fine while the car was running, but the pressure dropped off abnormally fast when the car was turned off. They suggested it was the fuel pump starting to go out. Maybe I was just in denial because I knew how much work it was to replace the pump, but I felt like there was something else wrong. I figured the fuel pressure regulator was likely to be the problem, and lo and behold, there was signs of a leak dripping right onto the intake manifold. Could that be the cause? I don't know how much a change in temperature affects gas, but I feel like it could be possible that it isn't a problem in the winter because the gas becomes just viscous enough that it doesn't leak badly. Idk, maybe I'm just trying to find the easy way out and should just give in and replace the pump.
    Any ideas? Thanks.

    Sorry if I left any important info out. I always end up typing a short story and still manage to leave out the most important parts.

  2. # ADS
    Circuit advertisement
    Join Date
    Always
    Location
    Advertising world
    Posts
    Many

  3. #2
    So no more runnin'... Namrepus28's Avatar
    Join Date
    Feb 2007
    Location
    Ontario, Canada
    Posts
    3,653
    Well, how expensive a fix is it going to be for you to correct the leak and change out the fuel pressure regulator? If it's less than the fuel pump (which is likely as that involves either a tank drop or a access hatch cut into the body) then why not give it a shot and see if that resolves the problem? Also, after a quick google search it sounds like the regulator could very well be the cause of your problem based on your description.

    It sounds like you've been troubleshooting your way through and have already eliminated possible causes and repaired other issues along the way, so you might as well tackle the last option left before settling on the pump replacement.

    EDIT: A new regulator is pretty inexpensive on Rock Auto. I'd definitely go this route before messing with the pump.
    -Derek- *Canada Forum Mod*
    1996 Camaro 3.8L A4
    2003 Bonneville SSEi A4
    Quote Originally Posted by RancidCamaro View Post
    "Cheat on her?! What do you think I am, some kind of an asshole?!"

  4. #3
    Newbie dom_'s Avatar
    Join Date
    Apr 2018
    Location
    Storm lake, IA
    Posts
    5
    Thanks for the input. I'll post an update when I get it replaced.

  5. #4
    Newbie dom_'s Avatar
    Join Date
    Apr 2018
    Location
    Storm lake, IA
    Posts
    5
    Well, that was quite an adventure. Planned on just using a mirror to locate and remove the fpr so I didn't have to remove the entire fuel rail. Was using a screwdriver to rotate the c clip around to be able to get my pliers on it, and while doing so I bent the housing over the clip. So, I ended up taking the whole rail off to get the fpr off, and went ahead and cleaned up all of the injectors while I was at it. That ~15 minute job turned into a whole day ordeal, but my car is running better than it ever has! Also, I was always confused because I thought '99s had a 16 gallon tank, but my car would die when I used up 12. Turns out I do have a 16 gallon tank, but the low fuel pressure meant I couldn't ever use the last 4 gallons. Glad to have that fixed.

  6. #5
    So no more runnin'... Namrepus28's Avatar
    Join Date
    Feb 2007
    Location
    Ontario, Canada
    Posts
    3,653
    Congratulations! Even though it was more work than you expected, it sounds like it was well worth it in the end. Nice job getting it sorted.
    -Derek- *Canada Forum Mod*
    1996 Camaro 3.8L A4
    2003 Bonneville SSEi A4
    Quote Originally Posted by RancidCamaro View Post
    "Cheat on her?! What do you think I am, some kind of an asshole?!"

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •