Results 1 to 4 of 4

Thread: L67 Breaking Up Under Mid to Heavy Throttle

  1. #1

    L67 Breaking Up Under Mid to Heavy Throttle

    Last week entering the hwy the car started to stumble and miss pretty bad. Under cruise of easy pedal pressure the car runs great. I have swapped all three coil and the ignition module. It really feels like there is spark loss. Even when the car is missing is still pulls hard under heavy throttle. I am getting no knock and there is no smoke.
    98 Buick GS Supercharged
    86 Buick GN Turbocharged
    85 Buick Regal Limited getting a BBB 455 soon
    06 Chevy Duramax Turbocharged
    11 Chevy Duramax Turbocharged

    I love boost.

  2. # ADS
    Circuit advertisement
    Join Date
    Always
    Posts
    Many

  3. #2
    Light Throttle
    Join Date
    Dec 2012
    Location
    Richmond VA
    Posts
    177
    I had this same issue after my rebuild, after doing some research the first thing i did was replace the coils. That didnt work, so i replaced the plugs and one wire that looked sketchy. Bingo full power at any boost level. I would replace plugs first, and then try your wires

  4. #3
    Someone else mentioned plugs and wires also. I will start with the plugs, wires are new from zpp
    98 Buick GS Supercharged
    86 Buick GN Turbocharged
    85 Buick Regal Limited getting a BBB 455 soon
    06 Chevy Duramax Turbocharged
    11 Chevy Duramax Turbocharged

    I love boost.

  5. #4
    Stupid #5 plug wits would get warm and droop down and short out against header. Installed no other wire and tied it up outta the way.
    Got to over 100 on the on ramp before slowing down to merge.
    98 Buick GS Supercharged
    86 Buick GN Turbocharged
    85 Buick Regal Limited getting a BBB 455 soon
    06 Chevy Duramax Turbocharged
    11 Chevy Duramax Turbocharged

    I love boost.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •