Results 1 to 3 of 3

Thread: Gotta cooling system problem for you guys

  1. #1
    Full Throttle ANGRY BIRD's Avatar
    Join Date
    Aug 2011
    Location
    Kansas City
    Posts
    954

    Gotta cooling system problem for you guys

    My buddy's 02 Impala (3.8) seems to be spurting coolant from the pressure cap, he replaced it and it's still doing it.

    From what I can remember he's replaced recently:

    Coolant elbows
    Water Pump
    Plenum gaskets
    radiator
    thermostat

    He said it didn't do it till he replaced the water pump and elbows if I recall.

    All I can think of is there has to be excessive pressure, but what's causing it?
    http://www.fullthrottlev6.com/forums/signaturepics/sigpic7444_1.gif

  2. # ADS
    Circuit advertisement
    Join Date
    Always
    Location
    Advertising world
    Posts
    Many

  3. #2
    Did he bleed the system?

  4. #3
    ┬─┬ ノ( ゜-゜ノ) triple_l82's Avatar
    Join Date
    Dec 2005
    Location
    (◉◞౪◟◉)
    Posts
    7,146
    holy dead post. man this was made in 2013, how did you even see it?
    Larry:
    1996 camaro- Ole Blue. the very very very long time consuming project car
    1997 camaro- VIPER- turbov6camaro, search the forum for more info
    1979 Mustang Cobra - dad passed and left it to me, gonna be a clean street/strip car
    2014 Silverado CCSB 4x4 LTZ diamond white. Daily driver

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •