+ Reply to Thread
Results 1 to 14 of 14
  1. #1
    Full Throttle Extreme! hevymetalg's Avatar
    Join Date
    Apr 2008
    Location
    honeybrook PA.
    Posts
    2,955

    HEATER HOSE HELP! (98 camaro v6)

    Anybody ever use regular heater hose to fix the factory hose leak? If so what size do i need to buy? help im trapped

  2. # ADS
    Circuit advertisement
    Join Date
    Always
    Location
    Advertising world
    Posts
    Many

  3. #2
    its a helicopter! That_Guy's Avatar
    Join Date
    Nov 2007
    Location
    Illinois
    Posts
    1,163
    Gamer IDs

    PSN ID: cjg1987

    3/8 will work
    October '11 ROTM
    2005 Mazda RX8 Sport 6spd
    Mazdaspeed Spec 2 Clutch/Trans, MazdaSpeed Struts/Shocks, Agency Power Mid-Pipe, RB REV8 Catback, RB REVi Intake. LS2 Ignition Coils in progress.

  4. #3
    Full Throttle Extreme! hevymetalg's Avatar
    Join Date
    Apr 2008
    Location
    honeybrook PA.
    Posts
    2,955
    Quote Originally Posted by That_Guy View Post
    3/8 will work
    no it wont, the connection opening on the water pump is 3/4 and the cap that secures it is even bigger, so i dont think i could expand the normal 3/4 heater hose over the whole thing and clamp it?

  5. #4
    Banned
    Join Date
    Aug 2008
    Location
    Louisiana, WHO DAT!
    Posts
    1,173
    Yea, it's around 3/4 or 1 inch

  6. #5
    Half Throttle evile1003's Avatar
    Join Date
    Dec 2005
    Location
    mechan Hicksville va
    Posts
    332
    if your talking about the heater core hose then u can cut the broke piece out and put new hose in with a conector.. or you can buy the whole assembly it around $180 and its dealer item only.. i only paid 120 shop cost

  7. #6
    Full Throttle Extreme! hevymetalg's Avatar
    Join Date
    Apr 2008
    Location
    honeybrook PA.
    Posts
    2,955
    Quote Originally Posted by evile1003 View Post
    if your talking about the heater core hose then u can cut the broke piece out and put new hose in with a conector.. or you can buy the whole assembly it around $180 and its dealer item only.. i only paid 120 shop cost
    yeah im goingto get the whole assembly and my gm dealer said he would give it to me for $130 when i get the money lol.my broking piece is at the connection so anybody do a good temp. fix that works?

  8. #7
    Banned
    Join Date
    Aug 2008
    Location
    Louisiana, WHO DAT!
    Posts
    1,173
    Quote Originally Posted by evile1003 View Post
    if your talking about the heater core hose then u can cut the broke piece out and put new hose in with a conector.. or you can buy the whole assembly it around $180 and its dealer item only.. i only paid 120 shop cost


    I have mine clamped - look on circled area. That's your heater hoze.

    Quote Originally Posted by heavymetalg
    yeah im goingto get the whole assembly and my gm dealer said he would give it to me for $130 when i get the money lol.my broking piece is at the connection so anybody do a good temp. fix that works?
    That's about how much it cost me. I used ductape to fix mine when it was broke - yea i know it's ghetto but it worked.
    Last edited by Leonard 3.8L; 03-27-2009 at 06:16 PM.

  9. #8
    Full Throttle Extreme! hevymetalg's Avatar
    Join Date
    Apr 2008
    Location
    honeybrook PA.
    Posts
    2,955
    Quote Originally Posted by Leonard 3.8L View Post


    I have mine clamped - look on circled area. That's your heater hoze.



    That's about how much it cost me. I used ductape to fix mine when it was broke - yea i know it's ghetto but it worked.
    thats a good fix, but mine is at the connection so that wont work for me, but thanks for the picture and thats a clean motor with some new parts.

  10. #9

    Red face Mine is busted at the connector

    Quote Originally Posted by hevymetalg View Post
    thats a good fix, but mine is at the connection so that wont work for me, but thanks for the picture and thats a clean motor with some new parts.
    I have the same problem- want to replace the hoses.

    I have a replacement, but I cant see how to get out that crazy torx screw at the base of the wheel well mount without removing a bunch of stuff- maybe even the strut.

    Had they put the screw on TOP, not only would gravity have helped maintain it there, it would have been EZ to replace.

    I'm thinking of busting off the old bracket and just tie-wrapping the new one on

  11. #10
    Banned
    Join Date
    May 2010
    Posts
    2
    Quote Originally Posted by hevymetalg View Post
    thats a good fix, but mine is at the connection so that wont work for me, but thanks for the picture and thats a clean motor with some new parts.
    Try this website, They might have the parts you need. http://www.v6fixit.com/
    Last edited by gearhead81; 05-17-2010 at 10:10 PM.

  12. #11
    (╯□)╯︵ /(.□ . \) Sparky's Avatar
    Join Date
    Feb 2009
    Location
    An igloo
    Posts
    3,243
    Gamer IDs

    Steam ID: SparkyJJO

    that site is pretty cool. I may have to get that kit at some point.
    - Jared
    1999 Camaro 3.8L A4, Mystic Teal Metallic. Cammed, headers. Stranos and Bilsteins, Founders LCAs, relo brackets, and adj. panhard. BLS + 5000k HID.
    2002 Trailblazer LS 4.2L 4x4, Forest Green Metallic and Herculiner Black two tone. Lifted.


  13. #12
    Banned
    Join Date
    May 2010
    Posts
    2
    Quote Originally Posted by Sparky View Post
    that site is pretty cool. I may have to get that kit at some point.
    I spent two weeks trying to find those dang parts and there hose kit fixed my problem.

  14. #13
    (╯□)╯︵ /(.□ . \) Sparky's Avatar
    Join Date
    Feb 2009
    Location
    An igloo
    Posts
    3,243
    Gamer IDs

    Steam ID: SparkyJJO

    I may have to order a set just to have them, in case they aren't around when I build the new engine!
    - Jared
    1999 Camaro 3.8L A4, Mystic Teal Metallic. Cammed, headers. Stranos and Bilsteins, Founders LCAs, relo brackets, and adj. panhard. BLS + 5000k HID.
    2002 Trailblazer LS 4.2L 4x4, Forest Green Metallic and Herculiner Black two tone. Lifted.


  15. #14
    Light Throttle Choppers's Avatar
    Join Date
    Dec 2009
    Posts
    169
    I did what the above person in the picture did. Mine was leaking at the connection and actually blew apart one morning while I was leaving. Cut the connection out and put that piece in. Been working fine like that for 2 years.
    1996 Chevrolet Camaro RS 3.8 - 199k and committed suicide
    Moroso CAI | 1LE Elbow | 17x9.5 Black z06 Motosports | Drilled/Slotted Rotors | Hawk Ceramics | Koni 4/4's | UMI Panhard Bar | UMI LCA's | Pacesetter Headers | Magnaflow Cat

    1999 Pontiac TransAm m6 - TSP LongTube Headers, TSP ORY, Magnamouth Bullet dumped, FAST 90 Intake with Direct Port, FAST TB 90mm, MS3, PRC 2.5 5.3 heads, LS2 Timing Set, TSP Ported Oil Pump, Full Tubular Suspension. 449rwhp/417tq.

+ Reply to Thread

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts