+ Reply to Thread
Page 1 of 3 1 2 3 LastLast
Results 1 to 15 of 44
  1. #1
    Half Throttle shomaro's Avatar
    Join Date
    Aug 2007
    Posts
    265

    reduced engine power

    was driving my car home from work and all of a sudden car slows down and reduced engine power light comes on and car wont go passed 20mph anyone know what this is? it seems im having one problem after an other

    1999 Trans am Drag car (long list of mods)
    2002 camaro (y87)(my toy)
    mods: intake, exhaust, built trans, 3500 stall, 4.10's, walbro fuel pump, 75 shot wet n20, tubular LCA's, Mickey Thomson et streets.
    2008 Ford Explorer (wifes car)
    2008 Ninja 650R
    2009 Ninja ZX6R
    1999 Mercury Cougar (DD)

  2. # ADS
    Circuit advertisement
    Join Date
    Always
    Posts
    Many

  3. #2
    So no more runnin'... Namrepus28's Avatar
    Join Date
    Feb 2007
    Location
    Ontario, Canada
    Posts
    3,586
    Anything other than slowing down? Did it slow down smoothly, like you had let off the gas?

    I'd guess it might be VATS if that was the case.
    -Derek- *Canada Forum Mod*
    1996 Camaro 3.8L A4
    2006 VW Jetta 1.9L TDI M5
    Quote Originally Posted by RancidCamaro View Post
    "Cheat on her?! What do you think I am, some kind of an asshole?!"

  4. #3
    Half Throttle shomaro's Avatar
    Join Date
    Aug 2007
    Posts
    265
    it just sounds like it wasnts to die it got me home going 15 the whole way i put the gas to the floor and nothing happens the engine sounded real ruff

    1999 Trans am Drag car (long list of mods)
    2002 camaro (y87)(my toy)
    mods: intake, exhaust, built trans, 3500 stall, 4.10's, walbro fuel pump, 75 shot wet n20, tubular LCA's, Mickey Thomson et streets.
    2008 Ford Explorer (wifes car)
    2008 Ninja 650R
    2009 Ninja ZX6R
    1999 Mercury Cougar (DD)

  5. #4
    So no more runnin'... Namrepus28's Avatar
    Join Date
    Feb 2007
    Location
    Ontario, Canada
    Posts
    3,586
    What year is your car?

    Sounds like a misfire perhaps, but when my car was misfiring w/ a busted thermostat I could still do more than 15mph...

    Is your check engine light on? If so, is it amber colored? Or was it flashing from amber to red as you drove?
    -Derek- *Canada Forum Mod*
    1996 Camaro 3.8L A4
    2006 VW Jetta 1.9L TDI M5
    Quote Originally Posted by RancidCamaro View Post
    "Cheat on her?! What do you think I am, some kind of an asshole?!"

  6. #5
    Half Throttle shomaro's Avatar
    Join Date
    Aug 2007
    Posts
    265
    its a 02 no lights are on except for the reduced engine power light would the maf have anything to do with it?

    1999 Trans am Drag car (long list of mods)
    2002 camaro (y87)(my toy)
    mods: intake, exhaust, built trans, 3500 stall, 4.10's, walbro fuel pump, 75 shot wet n20, tubular LCA's, Mickey Thomson et streets.
    2008 Ford Explorer (wifes car)
    2008 Ninja 650R
    2009 Ninja ZX6R
    1999 Mercury Cougar (DD)

  7. #6
    So no more runnin'... Namrepus28's Avatar
    Join Date
    Feb 2007
    Location
    Ontario, Canada
    Posts
    3,586
    Not sure on the MAF. Did you check under the hood for any oddities? Anything clogged? Anything missing, broken, detached? All fluid levels okay?

    Anyone else care to chime in with their ?
    -Derek- *Canada Forum Mod*
    1996 Camaro 3.8L A4
    2006 VW Jetta 1.9L TDI M5
    Quote Originally Posted by RancidCamaro View Post
    "Cheat on her?! What do you think I am, some kind of an asshole?!"

  8. #7
    Half Throttle shomaro's Avatar
    Join Date
    Aug 2007
    Posts
    265
    checked all connections and fluids also tried disconnecting the battery and nothing

    1999 Trans am Drag car (long list of mods)
    2002 camaro (y87)(my toy)
    mods: intake, exhaust, built trans, 3500 stall, 4.10's, walbro fuel pump, 75 shot wet n20, tubular LCA's, Mickey Thomson et streets.
    2008 Ford Explorer (wifes car)
    2008 Ninja 650R
    2009 Ninja ZX6R
    1999 Mercury Cougar (DD)

  9. #8
    So no more runnin'... Namrepus28's Avatar
    Join Date
    Feb 2007
    Location
    Ontario, Canada
    Posts
    3,586
    Found this online:

    "What causes a 2000 camaro to have reduced engine power?"

    IS the check engine light on? The computer has the capability of putting the car in a "limp home mode" if somethign is wrong.

    If no check engine light, your fuel filter may be clogged and blocking fuel or the fuel pump is getting weak.




    I'd start with the fuel filter, it would be the easiest and cheapest to replace. Has it been replaced before?
    -Derek- *Canada Forum Mod*
    1996 Camaro 3.8L A4
    2006 VW Jetta 1.9L TDI M5
    Quote Originally Posted by RancidCamaro View Post
    "Cheat on her?! What do you think I am, some kind of an asshole?!"

  10. #9
    Half Throttle shomaro's Avatar
    Join Date
    Aug 2007
    Posts
    265
    fuel filter was changed bout 3 months ago i did tap the end of my fuel rail for my wet kit but ive done it before with out any negative results

    1999 Trans am Drag car (long list of mods)
    2002 camaro (y87)(my toy)
    mods: intake, exhaust, built trans, 3500 stall, 4.10's, walbro fuel pump, 75 shot wet n20, tubular LCA's, Mickey Thomson et streets.
    2008 Ford Explorer (wifes car)
    2008 Ninja 650R
    2009 Ninja ZX6R
    1999 Mercury Cougar (DD)

  11. #10
    So no more runnin'... Namrepus28's Avatar
    Join Date
    Feb 2007
    Location
    Ontario, Canada
    Posts
    3,586
    Well I looked up your owner's manual and it was pretty useless..."take it into the dealer"...

    Maybe it's a PCM or ICM problem?

    I don't even have this feature on mine, sounds like it's a safety kajigger to save your engine from further damage.

    Aaaanybody else have this happen to them?
    -Derek- *Canada Forum Mod*
    1996 Camaro 3.8L A4
    2006 VW Jetta 1.9L TDI M5
    Quote Originally Posted by RancidCamaro View Post
    "Cheat on her?! What do you think I am, some kind of an asshole?!"

  12. #11
    Half Throttle shomaro's Avatar
    Join Date
    Aug 2007
    Posts
    265
    yea thanks alot i appreciate your help im running out of ideas

    1999 Trans am Drag car (long list of mods)
    2002 camaro (y87)(my toy)
    mods: intake, exhaust, built trans, 3500 stall, 4.10's, walbro fuel pump, 75 shot wet n20, tubular LCA's, Mickey Thomson et streets.
    2008 Ford Explorer (wifes car)
    2008 Ninja 650R
    2009 Ninja ZX6R
    1999 Mercury Cougar (DD)

  13. #12
    I'm goin' nonlinear! Jon's Avatar
    Join Date
    Dec 2004
    Location
    San Antonio, TX
    Posts
    38,004
    Have you unplugged the MAF yet?
    2007 Honda Civic EX Coupe | 2005 Pontiac Grand Prix GT
    "He has no enemies, but is intensely disliked by his friends.." - Oscar Wilde
    Mah blog! (Guns!) Slamfire <- Linky

  14. #13
    So no more runnin'... Namrepus28's Avatar
    Join Date
    Feb 2007
    Location
    Ontario, Canada
    Posts
    3,586
    Quote Originally Posted by GS Jon View Post
    Have you unplugged the MAF yet?
    Hooray, my hero! (or in other words, someone other than me responding to this thread)
    -Derek- *Canada Forum Mod*
    1996 Camaro 3.8L A4
    2006 VW Jetta 1.9L TDI M5
    Quote Originally Posted by RancidCamaro View Post
    "Cheat on her?! What do you think I am, some kind of an asshole?!"

  15. #14
    I'm goin' nonlinear! Jon's Avatar
    Join Date
    Dec 2004
    Location
    San Antonio, TX
    Posts
    38,004
    I'm just taking shots in the dark.
    2007 Honda Civic EX Coupe | 2005 Pontiac Grand Prix GT
    "He has no enemies, but is intensely disliked by his friends.." - Oscar Wilde
    Mah blog! (Guns!) Slamfire <- Linky

  16. #15
    So no more runnin'... Namrepus28's Avatar
    Join Date
    Feb 2007
    Location
    Ontario, Canada
    Posts
    3,586
    As am I. all I could find was the bit about the fuel system not working properly. Apparently if it's a misfire etc, the check engine light should be on as well...but it's not.
    Last edited by Namrepus28; 01-21-2008 at 10:26 PM.
    -Derek- *Canada Forum Mod*
    1996 Camaro 3.8L A4
    2006 VW Jetta 1.9L TDI M5
    Quote Originally Posted by RancidCamaro View Post
    "Cheat on her?! What do you think I am, some kind of an asshole?!"

+ Reply to Thread
Page 1 of 3 1 2 3 LastLast

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts